User Tools

Site Tools


Sidebar

Overview

Installation

MYSTIC -CFG

Visual Customization

Mystic Utilities (MUTIL)

Scripting Custom Modules

Quick Reference

What's New

config_ansi_editor

ANSI Editor

Mystic has its own inbuilt ANSI editor it's packed full of features for viewing, editing and creating ANSI files. Like all of Mystic's functions this is designed to work over any terminal connection.

Getting Started

There are a couple of ways to access the editor. There is a command line option to start the text editor.

mystic: -ansi<filename> 

If <filename> is supplied it will open that file otherwise it will create an empty buffer. e.g.

mystic -ansi text\gj-glue1.ans

You can also run Mystic -CFG then head to the 'Other' menu and select “ANSI Editor”.

The ANSI editor can load display files with color codes from PCBoard, Wildcat, CNET, Mystic's pipe codes, and ANSI. The editor can save in ASCII or Pipe Code or ANSI and includes variable line length saving for ANSI files as well as some display options that can be set specifically to Mystic BBS.

In this example the editor menu has been invoked by pressing the ESC key.

[X:01 Y:1    ] ATTR [OVR] [NORMAL] <^Z/Help> P:01 F1░ 2▒ 3▓ 4█ 5▀ 6▄ 7¦ 8Ì 9■ 0
┌─────────────────────────────────────────────────────────────────────────────┐
│ ¦ ···                                                          |!0    ··· Ì │
├─────────────────────────────────────────────────────────────────────────────┤
│█▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀|!4
│█|!1                                                                        █│
│█|!3    ╔════════════════════════ Draw Menu ═════════════════════════╗      █│
│█       ║                                                            ║      █│
│█       ║   >>   Foreground          a. ┌┐└┘─│├┤┴┬    b. ╔╗╚╝═║╠╣╩╦  ║      █│
│█       ║     ░███████████████       c. ı©È¥═│ãÁ¤Ð    d. ÍÀË¢─║ÃÂðÊ  ║      █│
│█|!2    ║            ^               e. ┼╬ÏÎÞÚ:S"´    F. ░▒▓█▀▄¦Ì■·  ║      █│
│▀▄▄▄▄▄▄▄║        Background          g. «»‗¾®¬²÷½¼    h. Ò±¶§ÛØõ°¹³  ║▄▄▄▄▄▄█│
├────────║     ░███████████████       i. ÓßÔÕµþÙýݯ    j. ¼!Ññ▄x¸¨¡¿  ║───────┤
│ ¦ ···  ║     ^                      k. Æ▲&᪠}Å↑↓    l. ã0`éÉR9ìí~  ║ ··· Ì │
├────────║                            m. ∟↔"óº‼ü¶úa                   ║───────┤
│█▀▀▀▀▀▀▀║  FG:07   color   BG:00                                     ║▀▀▀▀▀▀▄│
│█|!5    ║                            O Open File      # Keys Normal  ║      █│
│█|!7    ║                            S Save File      Q Quit Drawing ║      █│
│█       ╚════════════════════════════════════════════════════════════╝     |!8
│█                                                                           █│
│█                                                                           █│
│█|!6                                                                        █│
│▀▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄█│
└─────────────────────────────────────────────────────────────────────────────┘

Editor Menu Options

There are several hot keys that can be selected.

O - Open File

This will open a file explorer to a default directory specified as 'Text File Path' in the System Paths section of Mystic -CFG

A file mask is applied so that only ASCII or ANSI files with *.a?? extensions are displayed. Pressing enter on any file loads its contents in to the editor.

Note the options below include a CTRL-D to specify a directory path to open and TAB that will show/hide directories from the explorer view. The delete key will also allow files to be deleted from the Open File dialog box.

Below is a screenshot of the file explorer in action.

                                   (EOF)
      ╔═══════════════════════════ Select a File ═══════════════════════════╗
      ║ (Ctrl-D) Directory                         (TAB) Toggle Directories ║
      ║ c:\mystic\text\*.a??                                                ║
      ║                                                                     ║
      ║ File Name                                  Size  Date        Time   ║
      ║ amsghlp1.asc                               538b  17 Mar 2019 10:27a █
      ║ amsghlp2.asc                              1014b  17 Mar 2019 10:27a ░
      ║ ansichat.ans                                2kb  17 Mar 2019 10:27a ░
      ║ ansieditor.ans                              1kb  17 Mar 2019 10:27a ░
      ║ ansiflst.ans                               461b  17 Mar 2019 10:27a ░
      ║ ansigal.ans                                600b  17 Mar 2019 10:27a ░
      ║ ansigalh.ans                                1kb  17 Mar 2019 10:27a ░
      ║ ansigalv.ans                               396b  17 Mar 2019 10:27a ░
      ║ ansihelp.ans                               589b  17 Mar 2019 10:27a ░
      ║ ansimidx.ans                               671b  17 Mar 2019 10:27a ░
      ║ ansimidxhelp.asc                          1000b  17 Mar 2019 10:27a ░
      ║ ansimlst.ans                               768b  17 Mar 2019 10:27a ░
      ╚═════════════════════════════════════════════════════════════════════╝

S - Save File

This hot key opens a Save File dialogue box and allows you to set the following:

  • File Name - Set the full path and filename of the ANSI / ASCII you are saving.
  • Clear Screen - Save file with a clear screen code included. Default is 'Yes'.
  • Allow Abort - Options are 'Default' 'No' and 'Yes'. Default is 'Default'.
  • Pause Screen - Save file with a pause screen code included. Options are 'Default' and 'No'. Default is 'Default'.
  • Display Speed - Sets display speed emulation. Options are 'Full Speed', 300, 2400, 4800, 9600, 19200, 28800, 38400, 57600 and 115200. Default is 'Full Speed'.
  • File Type - Set file type (ANSI / ASCII / Pipe Code)
  • CRLF at EOF - If this is Yes, Mystic will save a CRLF at the end of the ANSI file so that the cursor moves to the next line. If No, then Mystic will not. Default is Yes.
  • Line Length - Sets the maximum number of characters to be saved per line in the .ANS file, or 0 for unlimited. The default of 0 is almost always the best choice unless reforming an ANSI to post as a text file to a message base.

Below is a screenshot of the Save File options.

    ╔══════════════════════════════ Save File ══════════════════════════════╗
    ║                                                                       ║
    ║      File Name │ c:\mystic\text\welcome.ans                           ║
    ║   Clear Screen │ Yes                                                  ║
    ║    Allow Abort │ Default                                              ║
    ║   Pause Screen │ Default                                              ║
    ║  Display Speed │ Full Speed                                           ║
    ║      File Type │ ANSI                                                 ║
    ║    CRLF at EOF │ Yes                                                  ║
    ║    Line Length │ 0                                                    ║
    ║                                                                       ║
    ║  Save   Abort Save                                                    ║
    ║                                                                       ║
    ╚═══════════════════════════════════════════════════════════════════════╝

Enter Key / Number Keys / Arrow Keys / Letter Keys (A-M)

Pressing the ENTER key will toggle the focus of the Foreground and Background selector. Then use the left/right arrow keys to change the colour of the Foreground or Background subject to which has focus applied.

Number keys can also be used to directly apply a colour setting for both Foreground (FG) and Background (BG) elements in this dialogue box.

Letter keys A - M can select which active Glyph set is required. The Sysop can then use F1 - F10 keys to draw Glyphs using the active set.

Q - Quit Drawing

This will close the ANSI editor and prompt the Sysop to save any unsaved work.

Block Options

  • The ANSI editor has block options. CTRL+B can be used to select a block of text to be centered on.
  • ANSI editor has a block option for filling a block with a character, an attribute or both.
  • ANSI editor has a block option to select a block and center text found within the selected block (using the center of the selected block as the center point)

Miscellaneous Notes

  • The ANSI editor shows a “File saved” confirmation box after saving and retains the changed filename between save dialog boxes
  • CTRL+X will also exit the ANSI editor, asking to save if the file has been changed first.
config_ansi_editor.txt · Last modified: 2019/03/24 06:00 by g00r00